weston-agl-driver-conf: add recipe
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston-agl-driver-conf.bb
1 SUMMARY     = "Weston systemd configuration to run as agl-driver user"
2 LICENSE     = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 inherit systemd allarch features_check
6
7 REQUIRED_DISTRO_FEATURES = "wayland systemd"
8
9 SRC_URI = "file://weston-agl-driver.conf"
10
11 do_configure[noexec] = "1"
12 do_compile[noexec] = "1"
13
14 do_install() {
15     # Install override drop-in
16     install -d ${D}${systemd_system_unitdir}/weston.service.d
17     install -m 0644 ${WORKDIR}/weston-agl-driver.conf ${D}${systemd_system_unitdir}/weston.service.d/
18 }
19
20 FILES:${PN} += "${systemd_system_unitdir}"
21
22 RDEPENDS:${PN} += "weston agl-users"