3f0e34f4b560f4c58b2090928e85b6ef453113d4
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / wayland-ivi-extension_2.0.2.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
7
8 SRCREV = "ff067a640451de46836200624ece7ac777977c30"
9 SRC_URI = "git://github.com/GENIVI/${BPN}.git;branch=2.0;protocol=http \
10         file://0001-Added-ivi-id-agent-to-CMake.patch \
11         file://0002-ivi-id-agent-added-ivi-id-agent.patch \
12         file://0003-ivi-controller-load-id-agent-module.patch \
13     "
14 SRC_URI_append_wandboard = " file://wandboard_fix_build.patch"
15
16 S = "${WORKDIR}/git"
17
18 DEPENDS = "weston virtual/libgles2 pixman wayland-native"
19
20 FILESEXTRAPATHS_prepend := ":${THISDIR}/wayland-ivi-extension:"
21
22 # workaround paralellism issue:
23 PARALLEL_MAKE = ""
24
25 inherit cmake
26
27 EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
28
29 FILES_${PN} += "${libdir}/weston/*"
30 FILES_${PN} += "${datadir}/wayland-protocols/stable/ivi-application/*"
31
32 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
33
34 EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"