agl-ivi-multimedia: pull virtual/pulseaudio-config conditionnaly
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / wayland-ivi-extension_1.13.0.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
7
8 SRCREV = "ede33c1c898eeaf673dd2c275e92763a5aabd066"
9 SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
10         file://0001-simple-id-agent-initial-commit.patch;patch=1 \
11         file://0002-ivi-controller-load-id-agent-module.patch;patch=1 \
12         file://0003-ivi-controller-add-resize-setting-suit-to-surface-si.patch \
13         file://0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch \
14 "
15 S = "${WORKDIR}/git"
16
17 DEPENDS = "weston virtual/libgles2 pixman wayland-native"
18
19 inherit cmake
20
21 EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
22
23 FILES_${PN} += "${libdir}/weston/*"
24 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
25
26 EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
27
28 FILESEXTRAPATHS_prepend := ":${THISDIR}/wayland-ivi-extension:"
29
30 SRC_URI_append_wandboard = " file://wandboard_fix_build.patch"
31
32 # workaround paralellism issue:
33 PARALLEL_MAKE = ""