ttf-dejavu: remove emoji glyphs from dejavu fonts
[AGL/meta-agl-demo.git] / recipes-graphics / ttf-fonts / ttf-dejavu_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2 DEPENDS += "fontforge-native"
3
4 # From the orginal work located at https://aur.archlinux.org/packages/ttf-dejavu-emojiless/
5
6 SRC_URI_append = "\
7     file://cleaner.py \
8     file://emoji.json \
9     "
10
11 do_install_prepend() {
12     for TTF in ${S}/*.ttf; do
13         fontforge -script ${WORKDIR}/cleaner.py ${TTF}
14     done
15 }