dbc87c9ac35a2be1834a8834b34480790c1b15d4
[AGL/meta-agl-demo.git] / recipes-extended / dlt-daemon / dlt-daemon_2.15.0.bb
1 SUMMARY = "Diagnostic Log and Trace"
2 DESCRIPTION = "This component provides a standardised log and trace interface, \
3 based on the standardised protocol specified in the AUTOSAR standard 4.0 DLT. \
4 This component can be used by GENIVI components and other applications as \
5 logging facility providing: \
6 - the DLT shared library \
7 - the DLT daemon, including startup scripts \
8 - the DLT daemon adaptors- the DLT client console utilities \
9 - the DLT test applications"
10 HOMEPAGE = "https://www.genivi.org/"
11 SECTION = "console/utils"
12 LICENSE = "MPLv2"
13 LIC_FILES_CHKSUM = "file://LICENSE;md5=8184208060df880fe3137b93eb88aeea"
14
15 DEPENDS = "dbus zlib pigz-native"
16 do_unpack[depends] += "pigz-native:do_populate_sysroot"
17
18 SRCREV = "e9a486a08fff6d3cc7133a350cec3ee10f463207"
19 SRC_URI = "git://git.projects.genivi.org/${BPN}.git;protocol=http \
20     file://0002-Don-t-execute-processes-as-a-specific-user.patch \
21     file://0004-Modify-systemd-config-directory.patch \
22     "
23 S = "${WORKDIR}/git"
24
25 inherit autotools gettext cmake systemd
26
27 # -fPIC is needed to prevent relocation errors when we compile gtest with
28 # Yocto security flags. See this issue for more details:
29 #
30 # https://github.com/google/googletest/issues/854
31 #
32 # If that issue is fixed, we can probably remove the manual -fPIC flags here.
33 OECMAKE_C_FLAGS += "-fPIC"
34 OECMAKE_CXX_FLAGS += "-fPIC"
35
36 PACKAGES += "${PN}-systemd"
37 SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
38 SYSTEMD_SERVICE_${PN} = "dlt-system.service dlt.service"
39 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
40 SYSTEMD_SERVICE_${PN}-systemd = "dlt-example-user.service \
41     dlt-dbus.service \
42     dlt-adaptor-udp.service \
43     dlt-receive.service"
44 SYSTEMD_AUTO_ENABLE_${PN}-systemd = "disable"
45
46 EXTRA_OECMAKE = "-DWITH_SYSTEMD=ON"
47
48 FILES_${PN}-doc += "/usr/share/dlt-filetransfer"
49
50 do_install_append() {
51    rm -f ${D}${bindir}/dlt-test-*
52 }