agl-demo: update meta-clang comment
[AGL/meta-agl-demo.git] / recipes-extended / agl-qemu-runner / agl-qemu-runner.bb
1 SUMMARY     = "AGL simple QEMU runner script"
2 LICENSE     = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
5 inherit systemd allarch
6
7 SRC_URI = "file://agl-qemu-runner.sh \
8            file://agl-qemu-runner@.service \
9 "
10
11 do_configure[noexec] = "1"
12 do_compile[noexec] = "1"
13
14 do_install() {
15     # Install template unit
16     install -d ${D}${systemd_system_unitdir}
17     install -m 0644 ${WORKDIR}/agl-qemu-runner@.service ${D}${systemd_system_unitdir}/
18
19     # Install script
20     install -D -m 0755 ${WORKDIR}/agl-qemu-runner.sh ${D}${sbindir}/agl-qemu-runner.sh
21 }
22
23 FILES:${PN} += "${systemd_system_unitdir}"
24
25 RDEPENDS:${PN} += "bash qemu"