kuksa-dbc-feeder: add recipe and dependencies
[AGL/meta-agl-demo.git] / recipes-devtools / python / python3-setuptools-git-versioning_1.7.4.bb
1 SUMMARY = "Use git repo data for building a version number according PEP-440"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://LICENSE;md5=f22e7cb81b49604c2450680982bdc067"
4 PYPI_PACKAGE = "setuptools-git-versioning"
5
6 DEPENDS = "python3-six-native"
7
8 SRC_URI[sha256sum] = "be2901afcb7c865e3b500a38183598657fd029a1a72c8d1dfc7fbffb5c227dac"
9
10 inherit pypi setuptools3
11
12 RDEPENDS:${PN} += " \
13     python3-setuptools \
14     python3-six \
15 "
16
17 BBCLASSEXTEND = "native"