window-management-client-grpc_git.bb: Bump SRCREV
[AGL/meta-agl-demo.git] / recipes-demo / window-management-client-grpc / window-management-client-grpc_git.bb
1 SUMMARY     = "Window management gRPC application"
2 DESCRIPTION = "AGL demonstration of window management using gRPC"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtwayland \
10            qtwayland-native libqtappfw grpc grpc-native \
11            "
12
13 PV = "2.0+git${SRCPV}"
14
15 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git;protocol=https;branch=${AGL_BRANCH}"
16 SRCREV  = "cb7aa009ef9873967152e716fb01fecc30d401f7"
17
18 S  = "${WORKDIR}/git"
19
20 inherit  meson pkgconfig
21
22 AGL_APP_NAME = "window-management-client-grpc"
23
24 do_install:append() {
25     install -d ${D}${sysconfdir}/xdg/AGL/window-management-client-grpc
26 }
27
28 RDEPENDS:${PN} += "libqtappfw qtbase-qmlplugins"