SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-demo / waltham-receiver / waltham-receiver_git.bb
1 SUMMARY     = "Waltham-receiver"
2 DESCRIPTION = "Waltham-receiver is a demo application for testing out Waltham"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
8
9 SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV  = "${AGL_APP_REVISION}"
11
12 PV = "1.0+git${SRCPV}"
13 S  = "${WORKDIR}/git"
14
15 # build-time dependencies
16 DEPENDS += "waltham wayland wayland-native \
17             gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
18
19 inherit cmake pkgconfig aglwgt
20
21 RDEPENDS_${PN} += " \
22         gstreamer1.0-plugins-base \
23         gstreamer1.0-plugins-good \
24         gstreamer1.0-plugins-bad \
25         waltham \
26 "