Update github.com git:// SRC_URIs
[AGL/meta-agl-demo.git] / recipes-demo / telematics-recorder / telematics-recorder_git.bb
1 SUMMARY     = "Telematics Recorder application"
2 DESCRIPTION = "AGL demonstration telematics recorder application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-telematics-demo-recorder"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9 DEPENDS = "glib-2.0 mosquitto"
10
11 PV = "1.0+git${SRCPV}"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-telematics-demo-recorder;protocol=https;branch=${AGL_BRANCH}"
14 SRCREV  = "${AUTOREV}"
15
16 S  = "${WORKDIR}/git"
17
18 inherit cmake aglwgt
19
20 RDEPENDS:${PN} += " \
21     agl-service-can-low-level \
22     agl-service-gps \
23     agl-service-network \
24     libmosquitto1 \
25 "