60cbdf595eba7b0e8292c3493e147d57d9149911
[AGL/meta-agl-demo.git] / recipes-demo / settings / settings_git.bb
1 SUMMARY     = "Settings application"
2 DESCRIPTION = "AGL demonstration Settings application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     libqtappfw \
11     qtquickcontrols2 \
12     qt-qrcode \
13     qtvirtualkeyboard \
14 "
15
16 PV = "1.0+git${SRCPV}"
17
18 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
19 SRCREV  = "${AGL_APP_REVISION}"
20
21 S  = "${WORKDIR}/git"
22
23 inherit qmake5 aglwgt
24
25 RDEPENDS:${PN} += " \
26     qt-qrcode \
27     agl-service-bluetooth \
28     agl-service-network \
29     agl-service-voice-high \
30     libqtappfw \
31 "