Added cannelloni to packagegroup-agl-demo
[AGL/meta-agl-demo.git] / recipes-demo / radio / radio_git.bb
1 SUMMARY     = "Radio for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating Radio on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & GPLv2+"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;branch=${AGL_BRANCH} \
10            file://presets-ALS.conf \
11            file://presets-CES.conf \
12            file://presets-FOSDEM.conf \
13 "
14 SRCREV  = "${AGL_APP_REVISION}"
15
16 PV = "1.0+git${SRCPV}"
17 S  = "${WORKDIR}/git"
18
19 # build-time dependencies
20 DEPENDS = "qtquickcontrols2 rtl-sdr"
21 DEPENDS += "libhomescreen libqtappfw"
22
23 inherit qmake5 aglwgt
24
25 # ALS, CES, FOSDEM available
26 AGL_RADIO_PRESETS_LOCALE ?= "CES"
27 do_install_append() {
28     install -d ${D}${sysconfdir}/xdg/AGL
29     install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
30     install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
31     install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
32     install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
33 }
34
35 FILES_${PN} += "${sysconfdir}/xdg/AGL/*"
36
37 RDEPENDS_${PN} += "agl-service-radio libqtappfw"