08e174f748de3a887fb2b36b0634fc7182bd773d
[AGL/meta-agl-demo.git] / recipes-demo / navigation / poiapp_git.bb
1 SUMMARY     = "AGL Reference POI application."
2 DESCRIPTION = "This application provides the function of destination search to AGL.  It uses the API provided by AGL Reference Navigation.  This application uses yelp WebAPI."
3 HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
4 SECTION     = "apps"
5
6 LICENSE          = "GPLv2"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
8
9 DEPENDS = " \
10     qtbase \
11     json-c \
12     libhomescreen \
13     libqtappfw \
14 "
15
16 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
17 SRCREV = "${AGL_APP_REVISION}"
18
19 S = "${WORKDIR}/git"
20
21 inherit cmake_qt5 pkgconfig aglwgt
22
23 RDEPENDS:${PN} = "qtbase libqtappfw"