SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-demo / navigation / ondemandnavi_git.bb
1 SUMMARY     = "AGL Reference On Demand Navigation application."
2 DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS += "qtquickcontrols2 \
10             qlibhomescreen \
11             qtlocation \
12             libqtappfw \
13 "
14
15 PV = "1.0+git${SRCPV}"
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
18 SRCREV = "${AGL_APP_REVISION}"
19
20 S = "${WORKDIR}/git"
21
22 inherit qmake5 aglwgt pkgconfig
23
24 RDEPENDS_${PN} += "qtlocation \
25                    flite \
26                    libqtappfw \
27                    openjtalk \
28                    gstreamer1.0 \
29                    ondemandnavi-config \
30 "
31
32 RPROVIDES_${PN} = "virtual/navigation"
33