5fa27aa5f3da4abe8f1d35e02ffe1df7936273f2
[AGL/meta-agl-demo.git] / recipes-demo / navigation / ondemandnavi_git.bb
1 SUMMARY     = "Navigation application."
2 DESCRIPTION = "AGL demonstration Navigation application based on QtLocation widget."
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
10
11 PV = "2.0+git${SRCPV}"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
14            file://navigation.conf \
15            file://navigation.token \
16 "
17 SRCREV = "d6b883ef6bdb63fb501b03d64c9a32bc29b7b2c7"
18
19 S = "${WORKDIR}/git"
20
21 inherit qmake5 pkgconfig agl-app
22
23 AGL_APP_ID = "navigation"
24 AGL_APP_NAME = "Navigation"
25
26 do_install:append() {
27     # Currently using default global client and CA certificates
28     # for KUKSA.val SSL, installing app specific ones would go here.
29
30     # VIS authorization token file for KUKSA.val should ideally not
31     # be readable by other users, but currently that's not doable
32     # until a packaging/sandboxing/MAC scheme is (re)implemented or
33     # something like OAuth is plumbed in as an alternative.
34     install -d ${D}${sysconfdir}/xdg/AGL/navigation
35     install -m 0644 ${WORKDIR}/navigation.conf ${D}${sysconfdir}/xdg/AGL/
36     install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
37 }
38
39 RDEPENDS:${PN} += " \
40     qtwayland \
41     qtbase-qmlplugins \
42     qtgraphicaleffects-qmlplugins \
43     qtquickcontrols-qmlplugins \
44     qtquickcontrols2-qmlplugins \
45     qtquickcontrols2-agl \
46     qtquickcontrols2-agl-style \
47     qtlocation \
48     flite \
49     libqtappfw \
50     openjtalk \
51     gstreamer1.0 \
52     ondemandnavi-config \
53 "