6c90808487b5190eb7fbe34d83d3297b68a41590
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
1 SUMMARY     = "AGL Qt AppFW Library"
2 DESCRIPTION = "libqtappfw"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 SECTION     = "libs"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     qtbase \
10     qtbase-native \
11     qtdeclarative \
12     qtwebsockets \
13     glib-2.0 \
14     bluez-glib \
15     connman-glib \
16     libmpdclient \
17     protobuf-native \
18     grpc-native \
19     protobuf \
20     grpc \
21     kuksa-databroker \
22 "
23
24 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
25 SRCREV  = "4694b211569e15dc8aa4e75b6fb70e75946e766d"
26 S       = "${WORKDIR}/git"
27
28 # PV needs to be modified with SRCPV to work AUTOREV correctly
29 PV = "2.0.1+git${SRCPV}"
30
31 inherit meson pkgconfig
32
33 EXTRA_OEMESON += "-Dprotos=${STAGING_INCDIR}"
34
35 RRECOMMENDS:${PN} += "bluez5 connman mpd"
36
37 BBCLASSEXTEND = "nativesdk"