509ccc4ab0f5b66136ed5255be723ac73cac439a
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
1 SUMMARY     = "AGL Qt AppFW Library"
2 DESCRIPTION = "libqtappfw"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 SECTION     = "libs"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtbase \
11     qtbase-native \
12     qtdeclarative \
13     qtwebsockets \
14     glib-2.0 \
15     bluez-glib \
16     connman-glib \
17     libmpdclient \
18     protobuf-native \
19     grpc-native \
20     protobuf \
21     grpc \
22 "
23
24 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
25 SRCREV  = "1234b2771bc45a885df54a779dfb8a125f315f93"
26 S       = "${WORKDIR}/git"
27
28 # PV needs to be modified with SRCPV to work AUTOREV correctly
29 PV = "2.0.1+git${SRCPV}"
30
31 inherit meson pkgconfig
32
33 RRECOMMENDS:${PN} += "bluez5 connman mpd"
34
35 BBCLASSEXTEND = "nativesdk"