d2de209a1904d70e00f8da43a43f53d4522eafd4
[AGL/meta-agl-demo.git] / recipes-demo / launcher / launcher_git.bb
1 SUMMARY     = "AGL Launcher Application"
2 DESCRIPTION = "AGL Launcher Application build with recipe method"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 DEPENDS = "\
9         qtbase \
10         qtdeclarative \
11         qtquickcontrols2 \
12         qtwebsockets \
13         qlibhomescreen \
14         wayland-native \
15         wayland \
16         qtwayland \
17         qtwayland-native \
18         agl-compositor \
19 "
20
21 PV      = "1.0+git${SRCPV}"
22
23 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
24 SRCREV  = "${AGL_APP_REVISION}"
25
26 S       = "${WORKDIR}/git"
27
28 inherit qmake5 systemd pkgconfig aglwgt
29
30 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
31
32 RDEPENDS:${PN} = "agl-service-homescreen"