Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl-demo.git] / recipes-demo / launcher / launcher_git.bb
1 SUMMARY     = "AGL Launcher Application"
2 DESCRIPTION = "AGL Launcher Application build with recipe method"
3 HOMEPAGE    = "https://git.automotivelinux.org/apps/launcher"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 DEPENDS = "\
9         qtbase \
10         qtdeclarative \
11         qtquickcontrols2 \
12         libqtappfw \
13         wayland-native \
14         wayland \
15         qtwayland \
16         qtwayland-native \
17         agl-compositor \
18         json-c \
19         applaunchd \
20 "
21
22 PV = "1.0+git${SRCPV}"
23
24 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
25            file://launcher.service \
26 "
27 SRCREV = "4be88c049f31b7659e09223857b92ca531835039"
28
29 S = "${WORKDIR}/git"
30
31 inherit qmake5 systemd pkgconfig
32
33 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
34
35 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
36
37 do_install:append() {
38     install -D -m0644 ${WORKDIR}/launcher.service ${D}${systemd_system_unitdir}/launcher.service
39 }
40
41 RDEPENDS:${PN} += " \
42     libqtappfw \
43     applaunchd \
44     homescreen \
45 "