Remove usage of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / hvac / hvac_git.bb
1 SUMMARY     = "HVAC application"
2 DESCRIPTION = "AGL demonstration HVAC application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qttools-native \
11     qtbase \
12     qtdeclarative \
13     qtquickcontrols2 \
14     libqtappfw \
15 "
16
17 PV = "2.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH} \
20            file://hvac.conf \
21            file://hvac.token \
22 "
23 SRCREV = "2f96cf1047608fa5bf83addc52695b1b7d23b28c"
24
25 S = "${WORKDIR}/git"
26
27 inherit qmake5 pkgconfig
28
29 do_install:append() {
30     # Currently using default global client and CA certificates
31     # for KUKSA.val SSL, installing app specific ones would go here.
32
33     # VIS authorization token file for KUKSA.val should ideally not
34     # be readable by other users, but currently that's not doable
35     # until a packaging/sandboxing/MAC scheme is (re)implemented or
36     # something like OAuth is plumbed in as an alternative.
37     install -d ${D}${sysconfdir}/xdg/AGL/hvac
38     install -m 0644 ${WORKDIR}/hvac.conf ${D}${sysconfdir}/xdg/AGL/
39     install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
40 }
41
42 FILES:${PN} += "${datadir}/icons/"
43
44 RDEPENDS:${PN} += " \
45     qtwayland \
46     qtbase-qmlplugins \
47     qtgraphicaleffects-qmlplugins \
48     qtquickcontrols2-agl-style \
49     libqtappfw \
50 "