Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
1 SUMMARY     = "Home Screen application"
2 DESCRIPTION = "AGL demonstration Home Screen application"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7 #LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9 DEPENDS = " \
10     qtbase \
11     qtdeclarative \
12     qtquickcontrols2 \
13     wayland-native \
14     wayland \
15     qtwayland \
16     qtwayland-native \
17     agl-compositor \
18     json-c \
19     qtwebsockets \
20 "
21
22 PV      = "1.0+git${SRCPV}"
23
24 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;nobranch=1"
25 SRCREV  = "09b5eb1b42910e84612a37a0fb44629c73eee3e7"
26
27 S       = "${WORKDIR}/git"
28
29 inherit qmake5 systemd pkgconfig
30
31 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
32
33 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
34
35
36 do_install:append() {
37
38     install -d ${D}/${bindir}
39     install -m 0644 ${B}/homescreen/HomeScreen ${D}/${bindir}/homescreen
40
41 }