22f5b73ece3176efd2c59c8ae66295d346ee7fbc
[AGL/meta-agl-demo.git] / recipes-demo / dashboard / dashboard_git.bb
1 SUMMARY     = "Dashboard application"
2 DESCRIPTION = "AGL demonstration Dashboard application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/dashboard"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = "qtquickcontrols2 qttools-native libqtappfw"
10
11 PV = "1.0+git${SRCPV}"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
14 SRCREV  = "${AGL_APP_REVISION}"
15
16 S  = "${WORKDIR}/git"
17
18 inherit qmake5 aglwgt
19
20 RDEPENDS:${PN} += " \
21     libqtappfw \
22     agl-service-signal-composer \
23 "