80f8edbb020f93cbddd3360c6ebb0e8b1d97ec2a
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / qt-cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster Receiver AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster remote display"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/agl-qt-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
8                     file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
9
10 DEPENDS = " \
11     wayland wayland-native \
12     qtwayland qtwayland-native \
13     qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
14     gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
15 "
16
17 PV = "1.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
20 SRCREV  = "${AGL_APP_REVISION}"
21
22 S  = "${WORKDIR}/git"
23
24 inherit cmake_qt5 pkgconfig aglwgt
25
26 RDEPENDS:${PN} += " \
27     gstreamer1.0-plugins-base \
28     gstreamer1.0-plugins-good \
29     gstreamer1.0-plugins-bad \
30 "