SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / qt-cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster Receiver AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster remote display"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/agl-qt-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
8                     file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
9
10 SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
11 SRCREV  = "${AGL_APP_REVISION}"
12
13 PV = "1.0+git${SRCPV}"
14 S  = "${WORKDIR}/git"
15
16 # build-time dependencies
17 DEPENDS += "wayland wayland-native \
18             qtwayland qtwayland-native \
19             qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
20             gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
21
22 inherit cmake_qt5 pkgconfig aglwgt
23
24 RDEPENDS_${PN} += " \
25         gstreamer1.0-plugins-base \
26         gstreamer1.0-plugins-good \
27         gstreamer1.0-plugins-bad \
28 "