c9842ff353528fb8237a18f1dd42577f49ab073b
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster receiver application"
2 DESCRIPTION = "AGL demonstration instrument cluster XDG remote display application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
8
9 DEPENDS = " \
10     wayland wayland-native \
11     agl-compositor \
12     gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
13 "
14
15 PV = "1.0+git${SRCPV}"
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH} \
18            file://cluster-receiver.service \
19 "
20 SRCREV  = "ce90cf8dd26d596d65e222a94e64aa51e1c33298"
21
22 S  = "${WORKDIR}/git"
23
24 inherit cmake pkgconfig systemd
25
26 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
27
28 do_install:append() {
29     install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
30 }
31
32 RDEPENDS:${PN} += " \
33     gstreamer1.0-plugins-base \
34     gstreamer1.0-plugins-good \
35     gstreamer1.0-plugins-bad \
36 "