7028d5fc1980dba50b9b658a3a6873f621bbec87
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster Receiver application"
2 DESCRIPTION = "AGL demonstration instrument cluster remote display application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
8
9 DEPENDS = " \
10     wayland wayland-native \
11     gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad agl-compositor \
12 "
13
14 PV = "1.0+git${SRCPV}"
15
16 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
17 SRCREV  = "${AGL_APP_REVISION}"
18
19 S  = "${WORKDIR}/git"
20
21 inherit cmake pkgconfig aglwgt
22
23 RDEPENDS:${PN} += " \
24     gstreamer1.0-plugins-base \
25     gstreamer1.0-plugins-good \
26     gstreamer1.0-plugins-bad \
27 "