Update github.com git:// SRC_URIs
[AGL/meta-agl-demo.git] / recipes-demo / cluster-dashboard / cluster-dashboard_git.bb
1 SUMMARY     = "Instrument Cluster Dashboard application"
2 DESCRIPTION = "AGL demonstration instrument cluster dashboard application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-dashboard"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & BSD"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
8                     file://app/cluster-gauges.qml;beginline=9;endline=48;md5=54187d50b29429abee6095fe8b7c1a78"
9
10 DEPENDS = " \
11     qtquickcontrols2 libqtappfw glib-2.0 \
12     wayland-native wayland qtwayland qtwayland-native \
13 "
14
15 PV = "1.0+git${SRCPV}"
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-dashboard;protocol=https;branch=${AGL_BRANCH}"
18 SRCREV  = "${AGL_APP_REVISION}"
19
20 S  = "${WORKDIR}/git"
21
22 inherit pkgconfig cmake_qt5 aglwgt
23
24 RDEPENDS:${PN} += " \
25     qtquickcontrols \
26     qtquickcontrols-qmlplugins \
27     qtquickcontrols2 \
28     qtquickcontrols2-qmlplugins \
29     libqtappfw \
30     agl-service-signal-composer \
31 "