Added cannelloni to packagegroup-agl-demo
[AGL/meta-agl-demo.git] / recipes-demo / alexa-viewer / alexa-viewer_git.bb
1 SUMMARY     = "Demo voice capabilities template viewer for Alexa voiceagent"
2 DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10         qtquickcontrols2 \
11         qlibhomescreen \
12         af-binder \
13         libqtappfw \
14         wayland-native \
15         wayland \
16         qtwayland \
17         qtwayland-native \
18 "
19
20 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
21 SRCREV  = "${AGL_APP_REVISION}"
22
23 PV = "1.0+git${SRCPV}"
24 S  = "${WORKDIR}/git"
25
26 inherit cmake_qt5 aglwgt
27
28 OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
29
30 RDEPENDS_${PN} = " \
31         libqtappfw \
32         libafbwsc \
33         qlibhomescreen \
34         agl-service-voice-high-capabilities \
35 "