d8af6888c7886907a05f665bfa3308c6ad349626
[AGL/meta-agl-demo.git] / recipes-demo / alexa-viewer / alexa-viewer_git.bb
1 SUMMARY     = "Demo voice capabilities template viewer for Alexa voiceagent"
2 DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtquickcontrols2 \
11     qlibhomescreen \
12     af-binder \
13     libqtappfw \
14     wayland-native \
15     wayland \
16     qtwayland \
17     qtwayland-native \
18     agl-compositor \
19 "
20
21 PV = "1.0+git${SRCPV}"
22
23 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
24 SRCREV  = "${AGL_APP_REVISION}"
25
26 S  = "${WORKDIR}/git"
27
28 inherit cmake_qt5 aglwgt
29
30 OECMAKE_CXX_FLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
31
32 RDEPENDS:${PN} = " \
33     libqtappfw \
34     libafbwsc \
35     qlibhomescreen \
36     agl-service-homescreen \
37     agl-service-voice-high-capabilities \
38 "