Convert to new override syntax
[AGL/meta-agl-demo.git] / recipes-demo / alexa-viewer / alexa-viewer_git.bb
1 SUMMARY     = "Demo voice capabilities template viewer for Alexa voiceagent"
2 DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtquickcontrols2 \
11     qlibhomescreen \
12     af-binder \
13     libqtappfw \
14     wayland-native \
15     wayland \
16     qtwayland \
17     qtwayland-native \
18 "
19
20 PV = "1.0+git${SRCPV}"
21
22 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
23 SRCREV  = "${AGL_APP_REVISION}"
24
25 S  = "${WORKDIR}/git"
26
27 inherit cmake_qt5 aglwgt
28
29 OECMAKE_CXX_FLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
30
31 RDEPENDS:${PN} = " \
32     libqtappfw \
33     libafbwsc \
34     qlibhomescreen \
35     agl-service-homescreen \
36     agl-service-voice-high-capabilities \
37 "