agl-service-audiomixer: update SRCREV
[AGL/meta-agl-demo.git] / recipes-demo / agl-service-audiomixer / agl-service-audiomixer_git.bb
1 SUMMARY     = "Audio Mixer Service Daemon"
2 DESCRIPTION = "AGL Audio Mixer Service Daemon"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-audiomixer"
4 SECTION     = "apps"
5 LICENSE     = "MIT & Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
7
8 DEPENDS = " \
9     glib-2.0 \
10     boost \
11     openssl \
12     systemd \
13     pipewire \
14     wireplumber \
15     protobuf-native \
16     grpc-native \
17     protobuf \
18     grpc \
19     kuksa-databroker \
20 "
21
22 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-audiomixer.git;protocol=https;branch=${AGL_BRANCH} \
23            file://agl-service-audiomixer.conf \
24            file://agl-service-audiomixer.token \
25 "
26 SRCREV  = "0ff3ef1b254364639fc42495bbcfb4760250990a"
27
28 PV = "2.0+git${SRCPV}"
29 S  = "${WORKDIR}/git"
30
31 inherit meson pkgconfig systemd
32
33 EXTRA_OEMESON += "-Dprotos=${STAGING_INCDIR}"
34
35 SYSTEMD_SERVICE:${PN} = "agl-service-audiomixer.service" 
36
37 do_install:append() {
38     # Currently using default global client and CA certificates
39     # for KUKSA.val SSL, installing app specific ones would go here.
40
41     # VIS authorization token file for KUKSA.val should ideally not
42     # be readable by other users, but currently that's not doable
43     # until a packaging/sandboxing/MAC scheme is (re)implemented or
44     # something like OAuth is plumbed in as an alternative.
45     install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
46     install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf ${D}${sysconfdir}/xdg/AGL/
47     install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
48 }
49
50 FILES:${PN} += "${systemd_system_unitdir}"
51
52 RDEPENDS:${PN} += "kuksa-databroker"