cc32ffbfd4fa0a2d7a67a33567b7fe04f5f3e86e
[AGL/meta-agl-demo.git] / recipes-demo / agl-service-audiomixer / agl-service-audiomixer_git.bb
1 SUMMARY     = "Audio Mixer Service Daemon"
2 DESCRIPTION = "AGL Audio Mixer Service Daemon"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-audiomixer"
4 SECTION     = "apps"
5 LICENSE     = "MIT"
6 LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
7
8 DEPENDS = "boost openssl nlohmann-json systemd pipewire wireplumber"
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-audiomixer.git;protocol=https;branch=${AGL_BRANCH} \
11            file://agl-service-audiomixer.conf \
12            file://agl-service-audiomixer.token \
13 "
14 SRCREV  = "aa1156632525720d1d6d205f1b7aad3be4161a09"
15
16 PV = "2.0+git${SRCPV}"
17 S  = "${WORKDIR}/git"
18
19 inherit meson pkgconfig systemd
20
21 SYSTEMD_SERVICE:${PN} = "agl-service-audiomixer.service" 
22
23 do_install:append() {
24     # Currently using default global client and CA certificates
25     # for KUKSA.val SSL, installing app specific ones would go here.
26
27     # VIS authorization token file for KUKSA.val should ideally not
28     # be readable by other users, but currently that's not doable
29     # until a packaging/sandboxing/MAC scheme is (re)implemented or
30     # something like OAuth is plumbed in as an alternative.
31     install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
32     install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf ${D}${sysconfdir}/xdg/AGL/
33     install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
34 }
35
36 FILES:${PN} += "${systemd_system_unitdir}"
37
38 RDEPENDS:${PN} += "kuksa-val"