84a43a86c5d26ef3c2d66116731d695f06707b1e
[AGL/meta-agl-demo.git] / recipes-demo-hmi / windowmanager / windowmanager_git.bb
1 SUMMARY     = "AGL WindowManager Application"
2 DESCRIPTION = "WindowManager"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 inherit qmake5 systemd
9 DEPENDS = " qtbase "
10
11 # for WindowManager:
12 DEPENDS += " wayland-ivi-extension "
13
14 LIC_FILES_CHKSUM = "file://windowmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
15 SRCREV  = "eeedc5e9e67917bd3346dbe5332e667757a3b28d"
16 # PV needs to be modified with SRCPV to work AUTOREV correctly
17 PV = "0.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/windowmanager.git;protocol=https;branch=${AGL_BRANCH}"
20
21 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
22
23 do_install() {
24     install -d ${D}/usr/AGL/${PN}
25     install -m 0755 ${B}/windowmanager/WindowManager ${D}/usr/AGL/${PN}/
26     
27     install -d ${D}${systemd_user_unitdir}
28     install -m 0644 ${S}/windowmanager/conf/WindowManager.service ${D}${systemd_user_unitdir}
29     install -m 0644 ${S}/windowmanager/conf/WindowManager.path ${D}${systemd_user_unitdir}
30
31     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
32     ln -sf ${systemd_user_unitdir}/WindowManager.path ${D}${sysconfdir}/systemd/user/default.target.wants
33 }
34
35 FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
36 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
37