Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / windowmanager / windowmanager_git.bb
1 SUMMARY     = "AGL WindowManager Application"
2 DESCRIPTION = "WindowManager"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 inherit qmake5 systemd
9 DEPENDS = " qtbase "
10
11 # for WindowManager:
12 DEPENDS += " wayland-ivi-extension "
13
14 LIC_FILES_CHKSUM = "file://windowmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
15
16 SRCREV  = "6f4e56d960719a28cfbebddbc5eb052b5c9df08f"
17 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
18
19 # PV needs to be modified with SRCPV to work AUTOREV correctly
20 PV = "0.0+git${SRCPV}"
21
22 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/windowmanager.git;protocol=https;branch=dab"
23
24 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
25
26 do_install() {
27     install -d ${D}/usr/AGL/${PN}
28     install -m 0755 ${B}/windowmanager/WindowManager ${D}/usr/AGL/${PN}/
29     
30     install -d ${D}${systemd_user_unitdir}
31     install -m 0644 ${S}/windowmanager/conf/WindowManager.service ${D}${systemd_user_unitdir}
32     install -m 0644 ${S}/windowmanager/conf/WindowManager.path ${D}${systemd_user_unitdir}
33
34     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
35     ln -sf ${systemd_user_unitdir}/WindowManager.path ${D}${sysconfdir}/systemd/user/default.target.wants
36 }
37
38 FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
39 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
40