Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / vod-server / vod-server_0.1.bb
1 DESCRIPTION = "Build VideoOnDemand server"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 #LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
5 #                  "  
6
7
8 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https;branch=dab"
9 SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
10             file://vod-demo.service"
11
12 S = "${WORKDIR}/git"
13 SRCREV = "38a2c807b3128c5a84538334c6ba18fe95a55734"
14 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
15
16 PV = "0.1+git${SRCPV}"
17
18 do_install() {
19         install -m 0755 -d ${D}${bindir}
20         install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
21
22         # Install VOD server systemd service (user)
23         if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
24             install -m 644 -p -D ${WORKDIR}/vod-demo.service ${D}${systemd_user_unitdir}/vod-demo.service
25
26             # Execute install manually for root user on behalf of systemctl script
27             # because it doesn't support user mode of systemd.
28             install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
29             ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/vod-demo.service
30         fi
31 }
32
33 FILES_${PN} += " \
34     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
35     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
36     "