427ea7cca65e8fd72db75f2a035af4a5759c2c38
[AGL/meta-agl-demo.git] / recipes-demo-hmi / settings / settings_git.bb
1 SUMMARY     = "Settings for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating Settings on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6
7 PV = "1.0+git${SRCPV}"
8 S  = "${WORKDIR}/git"
9
10 inherit qmake5
11
12 DEPENDS += "qtquickcontrols2"
13 # 'wgtpkg-pack' in af-main-native is required.
14 DEPENDS += "af-main-native"
15 # setting has binding, so af-binder is required.
16 DEPENDS += "af-binder"
17
18 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
19
20 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=http"
21 SRCREV  = "${AUTOREV}"
22
23 RDEPENDS_${PN} += " \
24     qtmultimedia-qmlplugins \
25     qtquickcontrols2-qmlplugins \
26     "
27
28 do_install() {
29     install -d ${D}/usr/AGL/apps
30     install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
31 }
32
33 FILES_${PN} += "/usr/AGL/apps/ \
34     /usr/AGL/apps/${PN} \
35     "