Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / settings / settings_git.bb
1 SUMMARY     = "Settings for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating Settings on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=dab"
10 SRCREV  = "32be14bbc8f05abaf7ef5cb3e96469afc193d1f0"
11 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
12
13
14 PV = "1.0+git${SRCPV}"
15 S  = "${WORKDIR}/git"
16
17 # build-time dependencies
18 DEPENDS += "qtquickcontrols2"
19
20 # runtime dependencies
21 RDEPENDS_${PN} += " \
22             agl-service-bluetooth \
23             agl-service-wifi"
24
25 inherit qmake5 aglwgt