Merge branch 'next'
[AGL/meta-agl-demo.git] / recipes-demo-hmi / settings-log-utils / settings-log-utils_git.bb
1 SUMMARY     = "App for log record"
2 DESCRIPTION = "AGL HMI Application for demonstrating Log Record on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings-log-utils"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings-log-utils;protocol=https;branch=master"
10 SRCREV = "${AUTOREV}"
11
12 PV = "1.0+git${SRCPV}"
13 S  = "${WORKDIR}/git"
14
15 # build-time dependencies
16 DEPENDS += "libqtappfw qtquickcontrols2 qtwebsockets opencv boost"
17 DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
18
19 # runtime dependencies
20 RDEPENDS_${PN} += " \
21             agl-service-bluetooth \
22             agl-service-network"
23
24 inherit qmake5 aglwgt