phone: add agl-service-telephony to RDEPENDS
[AGL/meta-agl-demo.git] / recipes-demo-hmi / phone / phone_git.bb
1 SUMMARY     = "Phone for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating phone on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV  = "${AGL_APP_REVISION}"
11
12 PV = "1.0+git${SRCPV}"
13 S  = "${WORKDIR}/git"
14
15 # build-time dependencies
16 DEPENDS += "qtquickcontrols2 \
17             qtmultimedia \
18             libqtappfw \
19             libhomescreen \
20             qlibwindowmanager \
21 "
22
23 inherit qmake5 aglwgt
24
25 RDEPENDS_${PN} += "agl-service-telephony qtmultimedia"