tbtnavi: add libqtapp + agl-service-navigation dependencies
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / tbtnavi_git.bb
1 SUMMARY     = "AGL Reference Navigation Cluster Streaming application"
2 DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtLocation widget."
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
8                     file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
9                     file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
10                     file://LICENSE.mapbox-variant;md5=79558839a9db3e807e4ae6f8cd100c1c \
11                     file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
12 "
13
14 DEPENDS += "qtbase \
15             qtquickcontrols2 \
16             qlibhomescreen \
17             qlibwindowmanager \
18             qtlocation \
19             libqtappfw \
20 "
21
22 PV = "1.0+git${SRCPV}"
23
24 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
25 #SRCREV  = "4a8b7a6301e4b093c99329d0a16fbee6c535f312"
26 SRCREV = "${AGL_APP_REVISION}"
27
28 S = "${WORKDIR}/git"
29
30 inherit qmake5 aglwgt pkgconfig
31
32 RDEPENDS_${PN} += "qtlocation \
33                    ondemandnavi-config \
34                    agl-service-navigation \
35                    libqtappfw \
36 "