POI App: Adjust display for AGL Distro 3.0
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
1 SUMMARY     = "AGL Reference POI application."
2 DESCRIPTION = "This application provides the function of destination search to AGL.  It uses the API provided by AGL Reference Navigation.  This application uses yelp WebAPI."
3 HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
4 SECTION     = "apps"
5
6 LICENSE          = "GPLv2"
7 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
8
9 inherit cmake_qt5 pkgconfig
10
11 DEPENDS += " qtbase libdbus-c++ json-c \
12            "
13
14 SRCREV="3e162a60c76dee1b4dede81db55e0fa6bae05433"
15 SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
16          file://config.xml \
17 "
18
19 S = "${WORKDIR}/git"
20
21 do_install_append() {
22    mkdir -p ${WORKDIR}/widget
23    install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
24    install -m 0755 ${D}/usr/bin/yelp-client ${WORKDIR}/widget/poi
25    zip -ju ${WORKDIR}/widget/poi.wgt ${WORKDIR}/widget/poi ${WORKDIR}/widget/config.xml
26
27    install -d ${D}/usr/AGL/apps
28    install -m 0644 ${WORKDIR}/widget/poi.wgt ${D}/usr/AGL/apps/
29 }
30
31 FILES_${PN} += " /usr/AGL/apps/poi.wgt "