Fixed demo recipes to auto-install wgt app at first boot
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
1 SUMMARY     = "AGL Reference POI application."
2 DESCRIPTION = "This application provides the function of destination search to AGL.  It uses the API provided by AGL Reference Navigation.  This application uses yelp WebAPI."
3 HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
4 SECTION     = "apps"
5
6 LICENSE          = "GPLv2"
7 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
8
9 inherit cmake_qt5 pkgconfig
10 inherit aglwgt
11
12 DEPENDS += " qtbase libdbus-c++ json-c zip-native \
13            "
14
15 SRCREV="3e162a60c76dee1b4dede81db55e0fa6bae05433"
16 SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
17          file://config.xml \
18 "
19
20 S = "${WORKDIR}/git"
21
22 do_install_append() {
23    mkdir -p ${WORKDIR}/widget
24    install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
25    install -m 0755 ${D}/usr/bin/yelp-client ${WORKDIR}/widget/poi
26
27    mkdir -p ${B}/package
28    zip -ju ${B}/package/poi.wgt ${WORKDIR}/widget/poi ${WORKDIR}/widget/config.xml
29
30 }