0249ce980abd6d1d49010e5305c01338e5258c28
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
1 SUMMARY     = "AGL Reference POI application."
2 DESCRIPTION = "This application provides the function of destination search to AGL.  It uses the API provided by AGL Reference Navigation.  This application uses yelp WebAPI."
3 HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
4 SECTION     = "apps"
5
6 LICENSE          = "GPLv2"
7 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
8
9 inherit cmake_qt5 pkgconfig
10 inherit aglwgt
11
12 DEPENDS += " qtbase json-c libnaviapi-agl \
13            "
14
15 RDEPENDS_${PN} =  " qtbase \
16                   "
17
18 SRCREV = "833cdb678636677c33088d67f9ebfdb6125ca900"
19 SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=eel \
20           "
21
22 S = "${WORKDIR}/git"
23