ondemandnavi: remove org.agl.naviapi.conf from recipe
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / ondemandnavi_git.bb
1 SUMMARY     = "AGL Reference On Demand Navigation application."
2 DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS += "qtquickcontrols2 \
10             qlibhomescreen \
11             qlibwindowmanager \
12             qtlocation \
13             qtaglextras \
14             libqtappfw \
15 "
16
17 PV = "1.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
20 SRCREV = "${AGL_APP_REVISION}"
21
22 S = "${WORKDIR}/git"
23
24 inherit qmake5 aglwgt pkgconfig
25
26 RDEPENDS_${PN} += "qtlocation \
27                    flite \
28                    libqtappfw \
29                    openjtalk \
30                    gstreamer1.0 \
31                    ondemandnavi-config \
32 "
33
34 RPROVIDES_${PN} = "virtual/navigation"
35