ondemandnavi: add libqtappfw to DEPENDS
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / ondemandnavi_git.bb
1 SUMMARY     = "AGL Reference On Demand Navigation application."
2 DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS += "qtbase \
10             qtquickcontrols2 \
11             qlibhomescreen \
12             qlibwindowmanager \
13             qtlocation \
14             qtaglextras \
15             libqtappfw \
16 "
17
18 PV = "1.0+git${SRCPV}"
19
20 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
21            file://org.agl.naviapi.conf \
22 "
23 SRCREV = "${AGL_APP_REVISION}"
24
25 S = "${WORKDIR}/git"
26
27 inherit qmake5 aglwgt pkgconfig
28
29 do_install_append() {
30    install -d ${D}/etc/dbus-1/session.d/
31    install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
32 }
33
34 RDEPENDS_${PN} += "qtlocation \
35                    flite \
36                    openjtalk \
37                    gstreamer1.0 \
38                    ondemandnavi-config \
39 "
40
41 RPROVIDES_${PN} = "virtual/navigation"
42