ondemandnavi: add patches for pipewire and running as non-root
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / ondemandnavi_git.bb
1 SUMMARY     = "AGL Reference On Demand Navigation application."
2 DESCRIPTION = "This application provides the function of Navigation to AGL. "
3 HOMEPAGE    = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 inherit qmake5 aglwgt pkgconfig
10
11 SRC_URI = "git://github.com/YoshitoMomiyama/aglqtnavigation.git;branch=master \
12            file://0001-switch-to-alsa-output.patch \
13            file://0002-update-permissions.patch \
14            file://org.agl.naviapi.conf \
15            "
16 SRCREV  = "a6930c2dff988e45e18f91a2368d829c08942b30"
17
18 DEPENDS += " qtbase qtquickcontrols2 \
19              qlibhomescreen \
20              qlibwindowmanager \
21              qtlocation qtaglextras \
22            "
23
24 RDEPENDS_${PN} += " qtlocation \
25                     flite \
26                     openjtalk \
27                     gstreamer1.0 \
28                     ondemandnavi-config \
29                   "
30
31 RPROVIDES_${PN} = "virtual/navigation"
32
33 S = "${WORKDIR}/git"
34
35 do_install_append() {
36    install -d ${D}/etc/dbus-1/session.d/
37    install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
38 }
39
40 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
41