Add recipe for mapviewer
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://mapviewer.service \
5     "
6
7 inherit systemd
8
9 SYSTEMD_PACKAGES = "${PN}"
10
11 do_install_append() {
12     # Install systemd unit files
13     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
14         install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
15     fi
16 }
17
18 FILES_${PN} += " \
19     ${systemd_system_unitdir}/mapviewer.service \
20     "