fe897709ab7a0d9936f6e78fcb46405b837f472f
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer-demo.bb
1 SUMMARY     = "Setting files of mapviewer for the AGL Demonstrator @ CES2017"
2 DESCRIPTION = "Setting files of mapviewer for the AGL Demonstrator @ CES2017"
3 LICENSE     = "MIT"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6 SECTION     = "apps"
7
8 inherit systemd
9
10 SRC_URI = " \
11         file://switch_off_mapviewer-demo.sh \
12         file://switch_on_mapviewer-demo.sh \
13         file://weston-mapviewer-demo.ini \
14         file://weston-mapviewer-demo.service \
15         "
16
17 do_install() {
18     # Map viewer demo
19     install -d ${D}/usr/AGL/${PN}
20     install -m 0755 ${WORKDIR}/switch_off_${PN}.sh ${D}/usr/AGL/${PN}
21     install -m 0755 ${WORKDIR}/switch_on_${PN}.sh ${D}/usr/AGL/${PN}
22
23     install -d ${D}${sysconfdir}/xdg/weston
24     install -m 0644 ${WORKDIR}/weston-${PN}.ini ${D}${sysconfdir}/xdg/weston/weston-${PN}.ini
25
26     install -d ${D}${systemd_system_unitdir}
27     install -m 0644 ${WORKDIR}/weston-mapviewer-demo.service ${D}${systemd_system_unitdir}
28     sed -i "s:/home/root:${ROOT_HOME}:" ${D}${systemd_system_unitdir}/weston-mapviewer-demo.service
29 }
30
31 ## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
32 ##
33 ## The 'weston-mapviewer-demo.service' is exclusive of default 'weston.ini',
34 ## it should be enabled/disabled by 'switch_on_mapviewer-demo.sh'/'switch_off_mapviewer-demo.sh'.
35 ##
36 #SYSTEMD_SERVICE_${PN} = "weston-mapviewer-demo.service"
37
38 FILES_${PN} += " \
39     ${systemd_system_unitdir} \
40     /usr/AGL/${PN}/ \
41     ${sysconfdir}/xdg/weston/${PN} \
42     "