95910da77b4c4e82afa3cac7acfbb11ceff87f8d
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer-demo.bb
1 SUMMARY     = "Setting files of mapviewer for the AGL Demonstrator"
2 DESCRIPTION = "Setting files of mapviewer for the AGL Demonstrator"
3 LICENSE     = "MIT"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6 SECTION     = "apps"
7
8 inherit systemd
9
10 SRC_URI = " \
11         file://weston-mapviewer-demo.ini \
12         file://weston-mapviewer-demo.conf \
13         file://weston-ready.conf \
14         file://mapviewer-demo-network-conf.service \
15 "
16
17 do_install() {
18     # Install tweaked weston configuration
19     install -d ${D}${sysconfdir}/xdg/weston
20     install -m 0644 ${WORKDIR}/weston-${PN}.ini ${D}${sysconfdir}/xdg/weston/weston-${PN}.ini
21
22     # Install weston service unit configuration over-ride drop-in
23     install -d ${D}${systemd_system_unitdir}/weston.service.d
24     install -m 0644 ${WORKDIR}/weston-mapviewer-demo.conf ${D}${systemd_system_unitdir}/weston.service.d
25
26     # Install cluster demo network configuration service unit
27     install -m 0644 ${WORKDIR}/mapviewer-demo-network-conf.service ${D}${systemd_system_unitdir}
28     # Add symlink to network.target.wants
29     install -d ${D}${sysconfdir}/systemd/system/network.target.wants
30     ln -s ${systemd_system_unitdir}/mapviewer-demo-network-conf.service ${D}${sysconfdir}/systemd/system/network.target.wants/
31
32     # Workaround for now to ensure that the windowmanager and its dependencies
33     # start after weston, which takes longer with gst-record enabled.
34     # This should be investigated a bit further and likely reworked into
35     # something more generically applicable.
36     install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
37     install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
38 }
39
40 FILES_${PN} += " \
41         ${sysconfdir}/xdg/weston/ \
42         ${systemd_system_unitdir} \
43 "