packagegroups: graphics: add noto-emoji to packagegroup
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer-demo.bb
1 SUMMARY     = "Setting files of mapviewer for the AGL Demonstrator"
2 DESCRIPTION = "Setting files of mapviewer for the AGL Demonstrator"
3 LICENSE     = "MIT"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6 SECTION     = "apps"
7
8 inherit systemd
9
10 SRC_URI = " \
11         file://weston-ready.conf \
12         file://mapviewer-demo-network-conf.service \
13 "
14
15 do_install() {
16     # Install cluster demo network configuration service unit
17     install -d ${D}${systemd_system_unitdir}
18     install -m 0644 ${WORKDIR}/mapviewer-demo-network-conf.service ${D}${systemd_system_unitdir}
19
20     # Add symlink to network.target.wants
21     install -d ${D}${sysconfdir}/systemd/system/network.target.wants
22     ln -s ${systemd_system_unitdir}/mapviewer-demo-network-conf.service ${D}${sysconfdir}/systemd/system/network.target.wants/
23
24     # Workaround for now to ensure that the windowmanager and its dependencies
25     # start after weston, which takes longer with gst-record enabled.
26     # This should be investigated a bit further and likely reworked into
27     # something more generically applicable.
28     install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
29     install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
30 }
31
32 FILES_${PN} += " \
33         ${sysconfdir}/xdg/weston/ \
34         ${systemd_system_unitdir} \
35 "